Titan Quest: Immortal Throne Discussion

Titan Quest: Immortal Throne Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Trainer Update
1 report(s) filed
Boost Trainer Update Priority for Titan Quest: Immortal Throne
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
D2D Trainer help
Switz_DoD  posted on Apr 07, 2007 6:40:31 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Switz_DoD
I didnt know that downloading from D2D would cause me such a headache when it comes to trainers until spending the last 2 days trying to find one compatable. I found one trainer (some sort of demo trainer) that works but doesnt offer thge one cheat I really want (skill inhancement and HP). I've been seeing stuff for CD/DVD Fixes that boast it allows trainers to work on D2D games, but I am computer illiterete and must be doing it wrong because they still do not work. Can someone please help me out and provide in baby step instructions what I must do. Thank you so much for any help.
Doltish  posted on Apr 08, 2007 12:07:43 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Doltish
What you are going to have to do is go to a website like Gamecopyworld and find their page for Titan Quest / TQ Immortal Thrones. Look for the "NO CD / Fixed EXE" file. What that's going to do is give you a new EXE file for your game. You want to go to your games directory, rename the "Titan Quest.exe" file to "Titan Quest.exe.old" or something like that, just to save it for the future. Now right-click the properties for your shortcut for Titan Quest, and in the target box change the target from "Titan QuestD.exe" to just plain "Titan Quest.exe".

Or if you are playing the D2D version of IT, then just drop the Tqit file in the directory where you see the TqitD file, and edit your shortcut appropriately.

This will allow you to use trainers. The game works exactly as before with two setbacks:

When a new patch comes out for the game (which won't happen for a little while anyway) you're going to have to do this process over again with a new Fixed EXE hack.

The second setback is that if you are playing the original TQ using the Fixed EXE, and then you want to start playing TQ: IT, then you *must* revert your old "Titan Quest.exe" file to the original version. When you startup TQ: IT it does something to the old game, and it will fail if you are using the Fixed EXE version.

But those are two minor problems, really.

Hope that helps!

Don't feel guilty about using a hacked version either. You can still play multiplayer and everything, and you paid for the game! So no harm in tweaking it a little bit to make it work for you!

[Edited by Doltish, 4/8/2007 12:08:39 PM]

Switz_DoD  posted on Apr 08, 2007 3:41:25 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Switz_DoD
Thanks man, I'll give it a try next time I get a chance. Do you want to know how it turns out?
Switz_DoD  posted on Apr 08, 2007 11:05:11 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Switz_DoD
I got an error. it says "The procedure entry point? GetRegionById@World@GAME@@QAPAVARRegion@2@ABVRRegionId@2@_N@Z could not be located in the dynamic link library Engine.dll."

I dloaded NoDVD EXE Fix and xtracted it to the game directory. I changed the old TQIT to TQIT old. I went into shortcut app and manually typed in Titan Quest because it would not let me Find Target.

Once that was all done I 2x clicked my shortcut and got the message. Then I went into folder and 2x clicked on the EXE file and got the same message. Do you think I downloaded the wronfg Fix?

Switz_DoD  posted on Apr 09, 2007 6:40:05 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Switz_DoD
Its working now. I dwnloaded the wrong version lol. Thanks so much for helping me on this. Now Im rolling through the game instead of backtracking to a merchant every 10 minutes!
jaypalace  posted on Nov 27, 2008 5:01:57 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to jaypalace
I know this is a abit old now but I recently bought TQIT and the trainer (by MAXI DMG) works fine except for two problems which are really leaving me stuck:

1.I used the level up feature but now I am not gaining any xp when I kill enemies!!! its happened also in another game i played but that was bc i had downloaded it, I legally bought this one but it still does this!!! I tried starting a new game with another non trainer character and it worked fine so i really think its the trainer that did something...

2. ALT+F4 is a shortcut to close the game so it cannot be used (really this is a detail)

Please help if you can!!!! thanks a bunch!!!

Page 1 of 1
  Post Reply
All times are (GMT -06:00) Central Time (US & Canada). Current time is 6:34:21 PM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Latest Trainer
Titan Quest: Immortal Throne Trainer
• Remove Item Requirements
• Remove Skill Requirements
• Super Speed
+ 12 more options
  Show all Cheats & Trainers
Latest Wallpaper
1024 x 768
1152 x 600
1280 x 960
1280 x 1024
1600 x 1200
• 1920 x 1200
Wallpaper #1 of 2   Show All