Aurora Features Requests Discussion

Page 1 of 1
Signup or Login to Post
  Steam Deck FAQ
  • Tier 7
    Send a message to Jaz10
    TIER 7
    Jaz10 posted on Jul 25, 2023 5:21:30 AM - Report post
     
    Please ask questions over in the official Steam Deck thread. Link

    The main thing to remember when trying to solve issues is that some games just will not work with Aurora.

    Some questions will have the most recent solution(mostly my preferred method), as well as outdated solutions that I felt the need to include for "just incase it works."

    I can't move the mouse, no touch input, or click on anything on the aurora screen?
    If you are having mouse/touch input issues on your screen that's normal, some games use up all the input and doesn't let aurora have it's own.

    First, make sure it is indeed the game messing with the input by going to your controller layout and change the right and/or left trackpad to mouse and the trackpad press to left and right click. Go back to aurora then check and see if still doesn't work. If it still doesn't, see if the game settings lets you change from fullscreen to windowed this has solved the issue for some games. If there is no option to do that then you will have to go to desktop mode since there is no solution for gaming mode currently. In desktop mode you should be able to switch between windows by pressing alt+tab (if you don't have a keyboard set your back button to right alt+tab, it must be right alt since the left alt wont work, and set tab as sub command), switch to the aurora window and if there still is no mouse input, switch to windowed mode by going to settings or by clicking alt+enter, or by typing -windowed on the games launch settings.

    Other notes
    -Make sure steam overlay is disabled, and enable developer mode.
    -On gaming mode, typing "-windowed, -borderless, -sw, etc" as launch commands used to work from what I read but not anymore.

    Aurora window is too small and can't easily navigate. Aurora has black bars on the sides which don't allow me to make the window larger to activate trainers. Can't see "activate trainer" button.

    Go to desktop mode if it helps, but you want to click on your profile icon on Aurora, click on appearance and check the box for "Maximize window on start."
    The latest Aurora version should've addressed this issue but if you can't see the trainer button then users have noted that there are scroll bars you can use on bottom and sides of screen.

    Do offline keys work on Steam Deck?

    No.

    Game doesn't open, only Aurora opens.

    There are many possible solutions which all have worked at one point for me.

    -Give it time, I've had games like Tales of Arise take a while to open, sometimes steam is doing something else in the background.
    -Force close the app and retry.
    -Run the game without STL, then retry with STL, make sure to check you are running the same proton that succesfully booted the game.
    -Try different protons, if you tried 8.X try a 7.X version, etc.
    -Try launching the game via Aurora, click on "Launch game," you might need to go to "trainer settings" and add the games executable to path. Note: some exe will work while others will not, Remnant 2 for example. I need to use the exe found in Remnant2>Binaries>Win64 not the one found in remnant2 folder.

    Steam Tinker Launch doesn't show up under compatibility tools.

    Steam was probably open when you installed STL, exit Steam and reopen it.

    My Games/Trainers doesn't show up in the left column of Aurora.

    The games in the left column are trainers that you have marked as a FAVORITE, not a list of installed games. Not all trainers in our database are Aurora compatible so these will have to be downloaded from the site. Provide more info and we can provide more help. -PWizard

    When running STL my screen is different, I get a prompt to run a program.

    You can click "none" and proceed like normal. Hit Main menu, game menu, etc.

    On STL I can't scroll to Aurora.exe when I'm selecting path.
    Enable your mouse by going to your controller layout and change the right and/or left trackpad to mouse and the trackpad press to left and right click. Scroll over to the right side and a scroll bar should appear letting you scroll to the exe.
    Or you can use touch and tap on right side of the screen to see the scroll bar.

    Do standalone trainers work?

    Yes, No, maybe? I haven't tried many, out of the few I did only one worked. It was FF12 but that game has issues running on desktop and cause mouse input issues on gaming so its unusable.
    If you want to check just send the path to the standalone trainer instead of Aurora. Some users have reported having had luck with some.

    Does Mobile App work?

    Yes.

    STL shows a blank screen.

    Open ProtonupQT and uninstall STL then reinstall.

    I get Module Engine: Failed checking at CreateToolhelp32Snapshot when trying to activate trainer.

    The staff are aware of this issue.
    No solution at the moment.

    My windows won't switch despite pressing the Steam button.
    This is an issue that happens when Developer mode isn't enabled. Make sure developer mode is enabled.

    Ubisoft games on Steam are not working.
    Every month Ubisoft does something to break their launcher. Proton is pretty good about fixing it within the day. So I recommend if possible to run proton experimental or always use the latest proton with Steam Tinker Launch when you run Ubisoft games.

    [Edited by Jaz10, 12/27/2023 12:36:49 AM]
  • Tier 7
    Send a message to Jaz10
    TIER 7
    Jaz10 posted on Jul 25, 2023 5:26:18 AM - Report post
     
    Do Epic games/Ubisoft games work with Aurora?

    Yes, I highly recommend you have an external keyboard with a trackpad and mouse attached. I also highly recommend you to use NonSteamLaunchers by Moraroy Link. If you chose not to use either of the recommended options its going to be more difficult.

    Do the first initial set up steps in Desktop mode, once you got it set up you can run it on game mode.
    First, add Aurora.exe (the same aurora.exe you use for Steam Tinker Launch) to your steam library as a non-steam game. Open steam on the bottom left corner of the window it will read "add a game" with a + sign next to it. Click on that, then on "add non-steam game" then look for your aurora.exe file. Run it and make sure it runs fine, which it should.
    Head over to the NonSteamLaunchers github, on the right of the screen under the about section it should read "Releases" click on the latest and download the Nonsteamlaunchers.desktop asset. Run it and install the store of your choice. After installing your launcher of choice it should tell you the directory path to get to the launchers exe file. Go to the Dolphin file manager follow the path. Once you get to the exe file right click and copy location. Open aurora.exe through steam and go to your game's trainer, press on trainer settings and add a path, paste the copied location but you must add "z:" to the front so Aurora can recognize it. it should look something like this z:/home/deck/.local/share/Steam/steamapps/compatdata/NonSteamLaunchers/pfx/drive_c/Program Files (x86)/Epic Games/Launcher/Engine/Binaries/Win64/EpicGamesLauncher.exe

    After that, press the launch button in Aurora which will launch the launcher, download your game and run it, the game should be detectable by Aurora now.



    [Edited by Jaz10, 12/26/2023 2:33:20 PM]
Page 1 of 1
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 7:23:30 AM