LOGIN  .  SIGNUP   .  REWARDS   .  RC STORE   .  SUPPORT 
/ / / / HELP?

Spore: Galactic Adventures Discussion

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Help?
 
Feodaran  posted on Oct 14, 2009 10:30:23 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Feodaran
ELITE
Okay I have this problem...I bought the Spore addon, it's an original, I have good PC specs and can run it all and stuff.

I got 2 trainers to try out, not from here, but both made by Kelsat. One of them doesn't work and crashes it, which is fine by me (really awkward key combinations anyway) and another one that works great, except the cell health cheat doesn't work but no problem.

I got to the space stage (using the working Kelsat +26 trainer, don't need it, but trying it out to get to the Space Stage at first). I clicked to skip the tutorial that Mission Control offer me then get out of my planet and then went to another planet as requested, which would be the part where I find ruins and have to scan them.

I go into the planet's orbit and go down into it, the screen freezes as the radar picks up something strange, which would be the ruins. But as I click the > button, the screen goes blank with greenish squares on the two sides of the screen and black all around the screen, and the ruins are nowhere to be seen.

I just look at this as a glitch, and restart (I saved after I got to the Space Stage) and went back to there, and again same problem. I turned Spore GA off again, start it up without the trainer and still there. I restart PC and start up without the trainer and again the problem is still there.

I paid for this game and expansion. All I seem to get are crashes and bugs everywhere I go. I never had these problems with the ordinary Spore. I don't want to have to start again because I shouldn't have to.

And although every other topic I've tried posting on this site has been unnoticed, I'm hoping wit this still being fairly new, it'd have some sort of activity and someone would be able to help.

Any ideas? Perhaps some patch or something? I tried scanning with the internet and letting it update and stuff when I first got it (last week).

And yes, I've looked on the internet and had no luck. I've looked on these message boards and had no luck either.

Thanks for any help that I get. I'll try and get it fixed while waiting for a response, and if I find one, I'll post it incase others need it.

 
Feodaran  posted on Oct 14, 2009 7:51:17 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Feodaran
ELITE
*Double Post*

Okay I reloaded it, tried going through the tutorial and still the same problem. I even did it without the trainer!

I started a new planet and it seems to be okay on that one. I'll keep the other one there to try and get it working somehow, or if someone here can still help me (and possibly others?).

Also I noticed I have to log in to download like every adventure I go into whilst on the main game...any way to just have all that are available at the moment be downloaded? I don't have a normal internet right now and don't want to have to get online to make use of the £30...

[Edited by Feodaran, 10/16/2009 11:29:18 AM]

Page 1 of 1
  Post Reply
 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 5:32:01 AM
Cheat Happens Premium
 
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Latest Trainer
Spore: Galactic Adventures Trainer
• Captain Health
• Unlimited Sprint
• Instant Captain Cooldowns
+ 9 more options
  Show all Cheats & Trainers