BioShock Discussion

BioShock Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Trainer Update
0 report(s) filed
Boost Trainer Update Priority for BioShock
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Trainer don't work under Vista 64bit
radde  posted on Sep 25, 2007 7:12:30 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to radde

i have some problems with getting this trainer to work.
I start the game, than start the trainer. Everything works fine until i enter the game and start playing the game crashes at the loading screen.

I started the trainer as Administrator and tried all other suggested solutions that 'r posted on this message board.

My System:
Windows Vista 64bit Ultimate
Intel Core2 Quad 2.4 gHz

Hope there is another solution that could help me.


PWizard  posted on Sep 25, 2007 7:21:42 AM - Report post

Send a message to PWizard
None of our trainers are designed for 64-bit operating systems but many have been found to work fine, but it may be necessary to run in compatibility mode (game and trainer). You can also try starting the trainer during the splash screen and see if that helps.
radde  posted on Sep 25, 2007 7:26:47 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to radde
Sad to say this dosn't helped

Seems that this trainer is uselesse for me

Good to say that your Stalker trainer work perfectly

[Edited by radde, 9/25/2007 7:28:47 AM]

fishy_joe  posted on Sep 25, 2007 7:37:08 AM - Report post

Send a message to fishy_joe
PWizard is right try it when the splash screen appears

[Edited by fishy_joe, 9/25/2007 7:37:30 AM]

Javelin  posted on Sep 25, 2007 11:26:05 AM - Report post

Current rank: 1.5 Stars. Next Rank at 500 Posts.
Send a message to Javelin
Also, when you start the trainer right click on the shortcut icon and click on "Run As Administrator" to start it.
MoogleStiltzkin  posted on Sep 28, 2007 6:31:19 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to MoogleStiltzkin
I'm using Vista 64 bit ultimate and the Bioshock mega trainer V1 and V2 work for me .....

First i will start the BioShock game. When the BioShock logo pops up, then i run the BioShock Mega trainer V2 using compatibility mode administrator.

When i load back my saved game, then i activate the cheats ... to activate it is the numlock numbers make sure your numlock is on of course :x

I don't know why you say it's not working, maybe you forgot to do whatever it was i mention.

Page 1 of 1
  Post Reply
All times are (GMT -06:00) Central Time (US & Canada). Current time is 5:26:34 AM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Latest Trainer
BioShock Trainer
• Unlimited Health
• Unlimited Eve
• Money
+ 6 more options
  Show all Cheats & Trainers
Latest Wallpaper
1024 x 768
• 1152 x 600
1280 x 960
• 1280 x 1024
1600 x 1200
• 1920 x 1200
Wallpaper #1 of 2   Show All