Lords of Xulima Discussion

Lords of Xulima Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Trainer Update
0 report(s) filed
Boost Trainer Update Priority for Lords of Xulima
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 2 of 2   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
Save Game Password
Tpek  posted on Nov 16, 2014 2:23:58 PM - Report post

Premium Plus
Send a message to Tpek
originally posted by Asibin2000

I've been trying to mess with this.. the developers put in some security..

thus far:
1. The password is the same to unzip the jxsave file
2. if you re-zip the jaxsave with the same password - you get a corruption
3. the jxsaveinfo file has some dates / times - i thought maybe they were using that info to open the jxsave correctly - i tried editing the jxsaveinfo file with the updated jxsave date/ time but that did not work
4. there is some kind of "code" in jxsaveinfo that is checking to make sure the jxsave is not edited - probably some kind of time / date stamp

Anyone get further than I did on the latest version? I'm running a max so I can't use cheat engine

Thought so.
Damn those jerks for making life harder for us

I managed to use Cheat Engine with the full version but so far only for gold successfully.

Perkus  posted on Dec 01, 2014 12:17:39 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Perkus
Hi guys, new here, just wanted to let people know that I figured out how to bypass the corruption error when trying to load an edited save file. It's actually really easy: simply DELETE the single line near the bottom in the related .jxsavinfo file which contains:

"Simple name="Code" value="nnnnnnnnn"

The n's will of course vary in your particular file, it's some sort of checksum / CRC. If the game doesn't find it, it allows the save to load by default! You do NOT need to mess with the dates to match the new, edited date/time at all. So it's pretty straightforward. This seems much simpler that messing around with Cheat Engine, as the unzipped save file is in nicely organized, very readable plain markup language. So you can edit inventory, character stats, game flags, etc., if you can figure out what everything is.

Note that both the .jxsav and the .jxsavinfo file are zipped, so you'll have to build 2 new zips, but only the former is password protected. So make sure you're building these right. Also make sure you're zipping them in traditional (PK)ZIP format, and not RAR or something like that like my WinRAR defaults to... While I didn't test it, I assumes it expects a particular archive format, the hex of the zipped file should start with "PK".

Happy cheating! Err, editing!

[Edited by Perkus, 12/1/2014 12:18:12 AM]

[Edited by Perkus, 12/1/2014 12:18:30 AM]

[Edited by Perkus, 12/1/2014 12:19:10 AM]

Asibin2000  posted on Dec 05, 2014 9:16:30 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Asibin2000
Perkus - you rock man! Works great
RachelEvans  posted on Feb 07, 2015 4:28:45 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to RachelEvans
Hi there - first post on these forums.

I usually don't worry about file editing because it's over my head, but this game is so frustrating I have no choice.

No matter what I do, I cannot get the game to load the new save file. I have done this:

* unzip and unencrypt old.jxsav
* unzip old.jxsavinfo
* edit old.jxsav with some minor change for testing
* save old.jxsav as new
* zip new.jxave to ZIP format, and re-encrypt it
* edit old.jxsavinfo to remove the check line
* save old.jxsavinfo as new
* zip new.jxsavingo to ZIP format

At this point, the two files are listed as .zip files. The file type is Compressed (ZIP).

* delete everything ever to do with old.jxsav and old.jxsavinfo
* start the game
* see that old is still there, and new is not there
* cry

Where is it getting old files from? I have scrubbed old.jxsav* completely from my machine, yet the game recreates it and loads it every time.

Why isn't it recognizing my new file as a game?

What am I doing wrong here?

Thanks for any help...

Edit: I have also tried saving the files as the original name and loading them that way, they simply load the old pre-edit version. I have NO IDEA where it is getting those from.

Possibly from the Steam cloud... which I have to trick to be able to delete entirely. I give up.

[Edited by RachelEvans, 2/7/2015 4:45:04 PM]

[Edited by RachelEvans, 2/8/2015 11:26:39 AM]

Page 2 of 2   •  First Page  •  Previous Page  •   Next Page  •   Last Page
  Post Reply
Go to page: 1  2 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 12:17:52 AM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Latest Trainer
Lords of Xulima Trainer
• Add CT
• Add CO
• Add SP
+ 9 more options
  Show all Cheats & Trainers