Sniper Elite 3 Discussion

Sniper Elite 3 Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Trainer Update
0 report(s) filed
Boost Trainer Update Priority for Sniper Elite 3
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Sniper Elite 3
ripside  posted on Jul 17, 2014 12:57:08 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to ripside
I have not encountered this before. I open steam and open the game. I go to open the trainer and when it does a window pops up saying I need to connect to the internet. I am always connected and have a great signal, no issues there. It also says I need to get a trainer key from CH. Since I have the trainer from you guys and opened it the regular and tried running it with administrator approval, it doesn't matter. This trainer, the last one all did the same. I tried deleting the file and downloading it again. It says again the trainer must be authenticated and please connect to the internet which I have been using all day. I can obtain an offline key from CH.
Also once I download it again, Norton is all over it and wants to block it. They have anew set of controls that does not allow me to go in and allow it to run. But I can still open it until I get the unfriendly message to connect and to get authenticated. What do you think guys? Last night for whatever reason, I was going to give up and there the trainer was, ready to use. Maybe I need to restart my pc in order to run the trainer. But that seems a bit much. Thanks for any help. I have just closed the firewall for a moment and ran the trainer, then popped it back on. There seems to be no issue and better still no box telling me to connect to the net or get authenticated. Strange. it all works fine with that little off and on of the fire wall, takes 5 seconds.

[Edited by ripside, 7/17/2014 1:39:39 AM]

LordJB  posted on Jul 17, 2014 1:31:04 AM - Report post

Current rank: 2 Stars. Next Rank at 1000 Posts.
Send a message to LordJB
It sounds like the AV system (Norton in your case.) is blocking it from connecting since you tried administrative privileges already so it's not that.
Page 1 of 1
  Post Reply
All times are (GMT -06:00) Central Time (US & Canada). Current time is 1:37:10 AM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Game Review
Latest Trainer
Sniper Elite 3 Trainer
• Health
• Ammo
• No Reload
+ 9 more options
  Show all Cheats & Trainers