Incredible Adventures of Van Helsing 2 Message Board
Our Incredible Adventures of Van Helsing 2 Trainer is now available and supports STEAM. Our Incredible Adventures of Van Helsing 2 message board is available to provide feedback on our trainers or cheats.
Incredible Adventures of Van Helsing 2 Trainer
REQUEST MORE OPTIONS
Requests not available
FILE UPDATE REQUEST
Requests not available
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 1 of 1
Signup or Login to Post
mega fps problems
  • Premium Plus
    Send a message to vampirechick
    ELITE
    vampirechick posted on May 25, 2014 3:25:41 PM - Report post
     
    anyone had an issue with fps on the mega platform which you have to overheat, i've dropped everything down and still get a v poor framerate (about 4fps) instead of 60+. I have 2*4g gtx760 in sli and have run even the most demanding games recently without any lag
    Intel Core I9 9900K
    EVGA GTX1080ti FTW3
    32G (2*16GB) Vengeance LPX3000 DDR4
    ASUS TUF Z390-Plus Gaming
    Corsair H100i V2
    W10 Pro X64
  • Current rank: 1.5 Stars. Next Rank at 500 Posts.
    Send a message to taylor30
    ELITE
    taylor30 posted on May 25, 2014 8:08:43 PM - Report post
     
    dont run it in SLI mode some games do not need or require it!
  • Premium Plus
    Send a message to vampirechick
    ELITE
    vampirechick posted on May 26, 2014 7:50:26 AM - Report post
     
    thats a waste of my hardware, besides isn't there some options to configure sli in the advanced graphics options of the game, also the nvidia control panel settings for van helsing are sli recommended.

    I've done some further research since my initial post and it seems many people on the net have been having the same problem at this part in the game, looks like bad optimization by the programmers, lookout for another hotfix/patch to fix this problem
    Intel Core I9 9900K
    EVGA GTX1080ti FTW3
    32G (2*16GB) Vengeance LPX3000 DDR4
    ASUS TUF Z390-Plus Gaming
    Corsair H100i V2
    W10 Pro X64
  • Current rank: 1.5 Stars. Next Rank at 500 Posts.
    Send a message to BigBodZod
    ELITE
    BigBodZod posted on May 26, 2014 12:40:07 PM - Report post
     
    quote:
    originally posted by vampirechick

    thats a waste of my hardware, besides isn't there some options to configure sli in the advanced graphics options of the game, also the nvidia control panel settings for van helsing are sli recommended.

    I've done some further research since my initial post and it seems many people on the net have been having the same problem at this part in the game, looks like bad optimization by the programmers, lookout for another hotfix/patch to fix this problem

    Well call it bad optimization/coding then, I bet there needs to be more done to make multi-GPU's work properly.

    I noticed that option too but if you do a test by disabling one of your GPU's and try it that way and it works, then you know.

    I can tell you it runs smooth as silk on my single AMD 7970 GHZ Edition card.

  • Premium Plus
    Send a message to vampirechick
    ELITE
    vampirechick posted on May 26, 2014 2:52:22 PM - Report post
     
    ok bigbodzod

    I'll give it a go, I managed to pass the stage I was on about thx to the trainer and a bit of persistance, but the game does have a habit of crashing in graphic intense scenes.
    Intel Core I9 9900K
    EVGA GTX1080ti FTW3
    32G (2*16GB) Vengeance LPX3000 DDR4
    ASUS TUF Z390-Plus Gaming
    Corsair H100i V2
    W10 Pro X64
  • Current rank: 2 Stars. Next Rank at 1000 Posts.
    Send a message to greenarrow2k6
    SAGE
    greenarrow2k6 posted on May 27, 2014 9:12:32 AM - Report post
     
    I'm also having this problem with a single GTX750 Ti. This is the only part of the game that gives me such low frame rate.
  • Premium Plus
    Send a message to vampirechick
    ELITE
    vampirechick posted on May 27, 2014 11:11:05 AM - Report post
     
    quote:
    originally posted by greenarrow2k6

    I'm also having this problem with a single GTX750 Ti. This is the only part of the game that gives me such low frame rate.

    oh trust me it won't be the only place, if you accept the quest to protect the halls of remembrance and put a flame tower as one of your traps it does the same thing

    Intel Core I9 9900K
    EVGA GTX1080ti FTW3
    32G (2*16GB) Vengeance LPX3000 DDR4
    ASUS TUF Z390-Plus Gaming
    Corsair H100i V2
    W10 Pro X64
  • Current rank: 1.5 Stars. Next Rank at 500 Posts.
    Send a message to BigBodZod
    ELITE
    BigBodZod posted on May 27, 2014 5:25:05 PM - Report post
     
    quote:
    originally posted by vampirechick

    quote:
    originally posted by greenarrow2k6

    I'm also having this problem with a single GTX750 Ti. This is the only part of the game that gives me such low frame rate.

    oh trust me it won't be the only place, if you accept the quest to protect the halls of remembrance and put a flame tower as one of your traps it does the same thing

    I'll let you know when I get to this location/quest in the game, just started and only level 8 so far, but will be moving forward soon.

Page 1 of 1
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 2:01:31 PM