Galactic Civilizations 3 Message Board  STATUS: ACTIVE - Trainers are still being considered and updated for this title as patches are released. There is no guarantee that a trainer can be made or updated but it will be reviewed by our staff.

Our Galactic Civilizations 3 Trainer is now available for version 4.1 HF and supports STEAM, EPIC STORE. Our Galactic Civilizations 3 message board is available to provide feedback on our trainers or cheats.
Galactic Civilizations 3 Trainer
REQUEST MORE OPTIONS
0 option(s) for voting
FILE UPDATE REQUEST
0 report(s) filed
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 61 of 61   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
  Galactic Civilizations 3 Trainer
  • Trainer Maker
    Send a message to 0x90
    STAFF
    0x90 posted on Apr 13, 2018 7:07:07 AM - Report post
     
    I've fixed the issues and added food as separated option. Fixed trainer will be posted soon.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to VoidRunner001
    ELITE
    VoidRunner001 posted on Dec 02, 2018 9:38:56 AM - Report post
     
    I'm just notifying you that there seems to be two different versions of the trainer available, version 3.05 and 3.04, both for all the DLCs. I'm just confused that there is two, do people still use the version 3.04 over 3.05? I'm just asking because I use the trainer manager and when im using it it always does that annoying boop noise multiple times saying there is an update even though i am using the latest version of the game and trainer but it always says i need to update no matter what i due thanks to the older version also being available. I'm just saying I think that everyone is probibly using the new version so having the older version also available at the same time is causing it to falsely say there is a new update even though i am using the newest version. Sorry to harp on but that boop noise is very annoying to me, if people are still using version 3.04 I'm sorry for complaining but I just hope this is just an oversight that can be fixed.
  • Trainer Maker
    Send a message to 0x90
    STAFF
    0x90 posted on Dec 02, 2018 9:40:47 AM - Report post
     
    The latest trainer version is 3.05, all others are older and outdated.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to lwpuma20
    ELITE
    lwpuma20 posted on Jan 22, 2021 4:03:51 AM - Report post
     
    just fyi the 3.96 trainer does work with the epic store version released on 01/21/2021

    [Edited by lwpuma20, 1/23/2021 2:23:56 PM]
  • Lead Moderator
    Send a message to CyPHeR369
    LEAD MODERATOR
    CyPHeR369 posted on Jan 22, 2021 4:41:23 AM - Report post
     
    Epic is not supported, that trainer is a couple years old and their are other versions to try , Current game version for the supported platform is 3.96

    To submit a request for a new distribution platform, please use our trainer requests system. Once at least 5 people request the same distribution, it will be available for funding. Please do NOT use the trainer option request system to request new platforms as they will be denied. Premium members at any level may request a new distribution as long as it’s done through the normal request system.

    [Edited by CyPHeR369, 1/22/2021 4:47:29 AM]
    "Light travels faster than sound. This is why some people appear bright until you hear them speak."
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to lwpuma20
    ELITE
    lwpuma20 posted on Jan 23, 2021 2:23:44 PM - Report post
     
    quote:
    originally posted by CyPHeR369

    Epic is not supported, that trainer is a couple years old and their are other versions to try , Current game version for the supported platform is 3.96

    To submit a request for a new distribution platform, please use our trainer requests system. Once at least 5 people request the same distribution, it will be available for funding. Please do NOT use the trainer option request system to request new platforms as they will be denied. Premium members at any level may request a new distribution as long as it’s done through the normal request system.

    [Edited by CyPHeR369, 1/22/2021 4:47:29 AM]

    yea i have 3.5 stuck on the brain from irl stuff going on i meant 3.96 version ill fix that

    [Edited by lwpuma20, 1/23/2021 2:24:12 PM]

  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to mandrillus
    ELITE
    mandrillus posted on Jan 28, 2021 9:31:03 AM - Report post
     
    I can't extract trainer. "access denied" by winrar.
    No matter what directory I choose.

    Tried other trainers, in same session, extraction gave no problem...
  • Site Support
    Send a message to DragonStryder
    SITE SUPPORT
    DragonStryder posted on Jan 28, 2021 10:51:13 AM - Report post
     
    quote:
    originally posted by mandrillus

    I can't extract trainer. "access denied" by winrar.
    No matter what directory I choose.

    Tried other trainers, in same session, extraction gave no problem...

    Something is probably blocking you then, most likely an AV or windows defender, turn everything off then try again.

    CheatHappens Lead Help Desk & Support Engineer.
    CheatHappens Trainer Monkeys Project Lead.
    Cheathappens Discord Server Manager.
Page 61 of 61   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 11:41:08 AM