Brink Message Board
Our Brink Trainer is now available and supports STEAM. Our Brink message board is available to provide feedback on our trainers or cheats.
Brink Trainer
REQUEST MORE OPTIONS
0 option(s) for voting
FILE UPDATE REQUEST
0 report(s) filed
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 1 of 1
Signup or Login to Post
Can't get past
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to gooberlindsey
    VETERAN
    gooberlindsey posted on May 11, 2011 4:35:11 PM - Report post
     
    Can't get the game to work: i start the game, create a character, etc. etc., but then when i try to start a game (ANY game, campaign, multi, etc.) the game just hangs on the black "Please wait" loading screen. It never completes. EVER.

    I'm on Vista home premium 64 with an ATI Radeon HD 4870 (1gb).

    All other sys specs way above recommends. Installed latest catalyst, hotfix to no avail.

    Anyone got any ideas? Thx!

    EDIT: Specified that my query is about the game itself, not the trainer.

    [Edited by gooberlindsey, 5/11/2011 4:52:50 PM]
  • Founder
    Send a message to PWizard
    FOUNDER
    PWizard posted on May 11, 2011 4:41:10 PM - Report post
     
    Are you referring to the game or the trainer?
    Chris O'Rorke (chris@cheathappens.com)
    Co-Founder: Cheat Happens.com

    Facebook . Vimeo . YouTube
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to gooberlindsey
    VETERAN
    gooberlindsey posted on May 11, 2011 4:51:19 PM - Report post
     
    Oh shoot! I'm totally referring to the *game*.

    Apologies, i should have been more specific.

    Was just wondering if anyone else had the same problem.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to ZtrydR
    ELITE
    ZtrydR posted on May 11, 2011 8:50:13 PM - Report post
     
    Maybe you have some corrupted files somewhere. Have you tried verifying the game cache?
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to gooberlindsey
    VETERAN
    gooberlindsey posted on May 12, 2011 3:45:45 PM - Report post
     
    Yeah, i even ended up reinstalling the whole thing -- second install download a heaping load of files from steam (rather than from the media), but again, no help.

    I was going to dual-boot my rig with windows 7 eventually, so i s'pose it's as good a time as any. If it doesn't work then... we'll see.

    Thx anyways.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to gooberlindsey
    VETERAN
    gooberlindsey posted on May 14, 2011 11:19:17 PM - Report post
     
    Solved it. Kinda. Switched to Win 7 and things seem to work now.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to Nodacrux7
    ELITE
    Nodacrux7 posted on May 15, 2011 3:06:22 AM - Report post
     
    Nice, glad to hear it.

    I bought Brink this morning and it's mad as!

    [Edited by Nodacrux7, 5/15/2011 3:35:07 AM]
Page 1 of 1
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 11:03:51 AM