BioShock 2 Discussion

BioShock 2 Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Trainer Update
0 report(s) filed
Boost Trainer Update Priority for BioShock 2
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 3   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
Trainer activates yet the num keys fail?
voidster  posted on Feb 09, 2010 8:36:45 PM - Report post

Send a message to voidster
Regarding the Trainer, Unlimited Health, Eve, Money, Adam,....

Ok, ive had this problem with ME2 as well. the trainer activates, yet i cant get any of the options to fire off. Ive tried running the trainer in compatibility mode, with admin rights. same effect. ive tried running the game in admin and running compatibility mode on it as well, i get the same result.

I run Comodo internet security (firewall, antivirus etc) ive shut the whole thing down just to make sure none of its features are active and i have the same results with the trainer. i could try uninstalling the whole thing and see if thats blocking something, but..ive set the trainer up in the firewall to trusted.

im running win 7 64 ultimate. Can you guys offer any other info on what i should try? im not saying your trainer is bad or anything, i know its something on my end..i just cant figure out what. im beginning to think i should reformat and go back to xp lol

naxe  posted on Feb 10, 2010 12:11:12 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to naxe
same here mate im running win 7 32 ultimate
Kiriai  posted on Feb 10, 2010 12:37:06 AM - Report post

Current rank: 1.5 Stars. Next Rank at 500 Posts.
Send a message to Kiriai
Okay guys when you have this problem the very first thing to do is make sure Numlock is ON, as your keyboard sends a different key signal based on on/off status and the trainer only looks for the on-signals, intentionally.

Barring that, however, try turning your antivirus off and downloading the trainer again. I've been told of scenarios where an AV will modify a program so that it runs but does nothing else.

Outside of those suggestions, I'm not sure, personally, what else to suggest. But with the lack of a reply previously I wanted to at least give you something of an idea to go on.

P.S.: Running Windows 7 Ultimate x64, all trainers run fine for me from shortcut that runs them in administrator mode, the checkbox on the bottom of the [Compatibility] tab.

[Edited by Kiriai, 2/10/2010 12:38:47 AM]

voidster  posted on Feb 10, 2010 12:54:23 AM - Report post

Send a message to voidster
id hope i have the sense to check if my numlock was enabled. but hey :P

numlock: check, yepper little light is on. Notepad seems to think so too. id say its on.

Antivirus, off, just about everything i can shut off in win 7..is OFF. AV, Firewall.. Nothing, no go.

trainer activates, but the actual functions do not. Ive run it in multiple compatibility modes, with admin rights ON and no options activate. Really weird.

Ryaz  posted on Feb 10, 2010 5:18:03 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Ryaz
does your keyboard have customizable modes?
i use the MS sidewinder and it changes it has 3 modes, and it automatically changes its mode to game-mode when i go ingame, this makes the keypad keys into macro buttons.
maby thats whats happening to you?
fusioniz  posted on Feb 10, 2010 7:23:12 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to fusioniz
im getting similar results. the trainer is activated but the effects are not working.any solutions?
PWizard  posted on Feb 10, 2010 7:44:29 AM - Report post

Send a message to PWizard
Ryuodjin  posted on Feb 10, 2010 8:45:47 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Ryuodjin
could you have edited trainers keys and left the key file where you keep trainers?
Page 1 of 3   •  First Page  •  Previous Page  •   Next Page  •   Last Page
  Post Reply
Go to page: 1  2  3 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 2:25:44 PM
Cheat Happens Premium
* Get 18,279 trainers for over 5,300 games
* Up to 400 new and updated trainers monthly
* Manage and update trainers through one app
* Request which games get new trainers
* Priority support with any problem
Game Review
Latest Trainer
BioShock 2 Trainer
• Unlimited Health
• Unlimited Eve
• Money
+ 8 more options
  Show all Cheats & Trainers