Settlers: Rise of an Empire Discussion

Settlers: Rise of an Empire Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Trainer Update
0 report(s) filed
Boost Trainer Update Priority for Settlers: Rise of an Empire
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
1.5 Trainer crashed my game?
knightmare777  posted on Jan 08, 2010 2:52:04 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to knightmare777
hello im using "1.5 4279" version of Settlers Rise of an Empire when i use 1.5 trainer and press F1 at main menu when i try to start the game the loading bar reaches the center and then crash to desktop..im using Windows 7 32bit i tried many compatibility mode to the Trainer and the Game still nothing is working my game is working if there's no Trainer on it
Vegetta  posted on Jan 09, 2010 1:43:26 AM - Report post

Current rank: 3 Stars. Next Rank at 4000 Posts.
Send a message to Vegetta
Have you read trainer troubleshooting? Link.
Shepuz  posted on Jan 17, 2010 4:30:36 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Shepuz
does the same thing for me actually. I updated my version with 1.5 patch, then used the 1.5 trainer, first launched the trainer, launched the game, pressed F1 (and frankly, up to this point the trainer hasn't given any error messages, no anti-vir popups or anything, everything seems to be doing just fine), after this I went to new campaign, and as I was starting a new game, the game crashed. Everything seemed to work entirely OK, I even got the "trainer activated" at the main menu screen after pressing F1, but everytime I try to start a new game/campaign, it crashes the game. Haven't tried starting a new game, playing a while, save, quit, run trainer, run game, load game yet. but I'll try that one too.
phatleet  posted on Feb 07, 2010 11:25:40 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to phatleet
Same problem here,and yes, I read the trainer troubleshooting, very helpfull...I would beleive that if someone says "I tried all compatibility modes" that would mean that he read in some extent the manual, this made me remember the infamous wow, where the solution to all mankind problems according to its gm's was "Delete the wtf folder"... But hey, I'm just a free lowlife member so why should you care?.


GT2007  posted on Feb 10, 2010 12:33:50 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to GT2007
Update your game to the version 1.7.1 and use that trainer. BTW if you are still using the 1.5 4279 because it is the version shared on the net, then you also need to know that they have removed the copy protection for the game, since the 1.6 update, and you can update it without worry that your game will not work anymore.

Do that and get the 1.7.1 trainer.

[Edited by GT2007, 2/10/2010 12:34:15 PM]

Page 1 of 1
  Post Reply
All times are (GMT -06:00) Central Time (US & Canada). Current time is 8:54:54 AM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Latest Trainer
Settlers: Rise of an Empire Trainer
• 100000 Gold
• Instant 3 Resource
• Instant 6 Troops
+ 2 more options
  Show all Cheats & Trainers
Latest Wallpaper
1024 x 768
1152 x 600
1280 x 960
1280 x 1024
1600 x 1200
• 1920 x 1200
Wallpaper #1 of 3   Show All