LOGIN  .  SIGNUP   .  REWARDS   .  RC STORE   .  SUPPORT 
/ / / / GLITCHES

Elder Scrolls 4: Oblivion Discussion

 
Elder Scrolls 4: Oblivion Cheats and Codes for XBox 360
 

Message Board for XBox 360 version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Glitches
 
Freck  posted on Apr 14, 2008 5:06:14 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Freck
ELITE

I'm guessing we've all found out one way or another that Oblivion is the grandaddy of all funny glitches ever to be accidentally put in a game.

For instance, I'm sure at one point we've all experienced what it's like to close a door on a dead body... (and if you haven't, go do it now, it's a scream.)

Anyway i was wondering if anyone has found any funny glitches of their own? Share the horror stories here!

Here's one i found whilst having a proper around:

turn the difficulty right down and go on a killing spree in a town (it has to be a town with a bridge, i recommend Leyawin or Bravil). Then once you've killed everyone find a character that is "invincible" ie. only goes unconsious when you hit them. Lure the character onto the bridge and make them unconsious, then quickly throw their body into the water and wait for them to wake up....

i won't spoil the end for anyone that hasn't done this yet!

(edit) It's also best viewed from down in the river with the body.

[Edited by Freck, 4/14/2008 5:10:04 PM]

 
erwin_rommel  posted on Apr 17, 2008 10:11:56 AM - Report post

Current rank: 1.5 Stars. Next Rank at 500 Posts.
Send a message to erwin_rommel
ELITE
i don't remember Leyawin having a bridge...
 
Patr10t  posted on Jul 14, 2008 2:30:29 PM - Report post

Current rank: 2 Stars. Next Rank at 1000 Posts.
Send a message to Patr10t
AUTHOR
The only actual Glitches I know of aren't good ones, they freeze your game, but it is fun to push and kick ppl off bridges and cliffs.
 
LimyMonkey  posted on Jul 16, 2008 11:05:29 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to LimyMonkey
ELITE
I have not tried this particular glitch.. but I have heard from my friends (pretty reliable) this glitch to get infinite sigil stones. First off, you must have bought the wizard's tower and have purchased all upgrades for it in game. You go on top of the alchemy fire, save game and go back to dashboard. You must then delete wizard's tower from your hardrive. When you go back into Oblivion, you should be inside of a village. near you is supposed to be a place that you can take sigil stones for free. When you save and redownload the wizard's tower expansion, you are to be back in the wizard's tower where you saved before.

i currently do not have Oblivion with me.. it would help greatly if somebody tried this glitch and told me if it works.

[Edited by LimyMonkey, 7/16/2008 11:06:55 PM]

Page 1 of 1
  Post Reply
 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 10:12:50 PM
Cheat Happens Premium
 
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Latest Wallpaper
1024 x 768
• 1152 x 600
1280 x 960
• 1280 x 1024
1600 x 1200
• 1920 x 1200
Wallpaper #1 of 3   Show All