Civilization 4 Message Board  STATUS: ACTIVE - Trainers are still being considered and updated for this title as patches are released. There is no guarantee that a trainer can be made or updated but it will be reviewed by our staff.

Our Civilization 4 Trainer is now available and supports RETAIL. Our Civilization 4 message board is available to provide feedback on our trainers or cheats.
Civilization 4 Trainer
REQUEST MORE OPTIONS
0 option(s) for voting
FILE UPDATE REQUEST
2 report(s) filed
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 3 of 5   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
Civilization IV 1.7.4 CH Trainer
  • Current rank: 3.5 Stars. Next Rank at 8000 Posts.
    Send a message to forty-two
    AUTHOR
    forty-two posted on Jul 26, 2007 11:40:00 AM - Report post
     
    If you select something to build and then go into the city's menu, you can unselect that project. It won't pop-up again.

    Sorry, that wasn't exactly the best description.

    1.) Menu pops up
    2.) You select Settler.
    3.) You click on the city's name
    4.) At the bottom left corner click on the part that says, "Settler (1)"

    If you need to build more stuff, just go into that city menu and pick something to build. After it is built, the pop-up will re-appear.
    /--\
  • Founder
    Send a message to Caliber
    FOUNDER
    Caliber posted on Jul 26, 2007 12:48:30 PM - Report post
     
    i am not ignoring your feedback. i guess i need to look at this again and i will when i get a second. finishing up some other work for CH and then i will get back to this. also, maybe you can test beyond the sword and see if you are getting the same problems with both trainers?


    thanks-

    Cal
    Trainer Creator
    www.cheathappens.com
  • Current rank: 2 Stars. Next Rank at 1000 Posts.
    Send a message to JamieK
    ELITE
    JamieK posted on Jul 26, 2007 9:25:44 PM - Report post
     
    well, i don't have the expansions at the moment.
  • Founder
    Send a message to Caliber
    FOUNDER
    Caliber posted on Jul 29, 2007 6:39:23 AM - Report post
     
    ok i tested civilization beyond the sword with the russians, etc. and it seems to work perfectly. i cannot replicate any crashes in the game. the Civ IV trainer (not beyond the sword) did have some problems and i fixed it. here is the version i am playing with:


    at main menu:

    go to ADVANCED
    then select

    ABOUT THIS BUILD

    which shows:

    for Beyond the Sword my version is:
    3.0.0.91 (74697)

    and for Civ IV by itself my version is:
    1.7.4.0

    I am uploading the new trainer for CIV IV by itself to eliminate the crashes from before. Remember that you only run ONE trainer and you must run the correct trainer for the game you are playing (either CIV IV by itself or BEYOND THE SWORD by itself).

    If these trainers aren't working for you then likely something is interfering with the trainer writing to your game OR we have different versions.

    If there is a new version of the CIV IV or BEYOND THE SWORD out then i am not aware of it. what version is it. where do you get it? etc.

    best,
    Cal
    Pwiz will post the new version(s) shortly-


    [Edited by Caliber, 7/29/2007 6:40:09 AM]
    Trainer Creator
    www.cheathappens.com
  • Founder
    Send a message to Caliber
    FOUNDER
    Caliber posted on Jul 29, 2007 6:50:41 AM - Report post
     
    also just for information, most trainers are looking in memory for the game based on it's name. the name has to be exact.

    for these games, the name is:

    Civ4BeyondSword.exe

    and

    Civilization4.exe

    note that the capitalization must be exact and the spelling must be exact. sometimes updates or cracked versions of the game the .exe is named differently, etc. the trainer will not find

    civ4beyondsword.exe

    when it is looking for

    Civ4BeyondSword.exe

    etc. that is why you will get the "loading" blinking over and over if it hasn't found the right thing. the same thing can occur with a mod or a different version of the game that might have renamed a .dll in the game. the .dll

    CvGameCoreDLL.dll

    is important in this game and in this trainer. if it has been modified or if it has been renamed in some way

    (for instance cvGameCoredll.dll or CvGameCoreDLL.DLL) well you get the idea. the trainer won't work because the spelling and capitalization is important.

    maybe this might explain some probs. i cannot control these types of things!

    best,
    Cal
    Trainer Creator
    www.cheathappens.com
  • Founder
    Send a message to PWizard
    FOUNDER
    PWizard posted on Jul 29, 2007 7:37:58 AM - Report post
     
    updated trainer posted! please re-download.
    Chris O'Rorke (chris@cheathappens.com)
    Co-Founder: Cheat Happens.com
  • Current rank: 3.5 Stars. Next Rank at 8000 Posts.
    Send a message to forty-two
    AUTHOR
    forty-two posted on Aug 01, 2007 7:43:12 PM - Report post
     
    I downloaded it and it all worked at first except for the 1-turn research. I tried the no-cd fix, put the trainer in the game folder, and tried loading the trainer before and after the game loaded. Nothing was working.

    Then, as a last resort, I uninstalled and reinstalled it. It works fine now, and I love it. So, if anyone has problems, uninstall and then reinstall it. It was worth the wait.
    /--\
  • Founder
    Send a message to Caliber
    FOUNDER
    Caliber posted on Aug 02, 2007 1:17:17 PM - Report post
     
    thanks for the nice comments and for the info.

    best,
    Cal

    Trainer Creator
    www.cheathappens.com
Page 3 of 5   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 4:20:29 PM