Civilization 4: Beyond the Sword Message Board  STATUS: ACTIVE - Trainers are still being considered and updated for this title as patches are released. There is no guarantee that a trainer can be made or updated but it will be reviewed by our staff.

Our Civilization 4: Beyond the Sword Trainer is now available and supports RETAIL. Our Civilization 4: Beyond the Sword message board is available to provide feedback on our trainers or cheats.
Civilization 4: Beyond the Sword Trainer
REQUEST MORE OPTIONS
0 option(s) for voting
FILE UPDATE REQUEST
0 report(s) filed
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 4 of 7   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
Civ4: Beyond the Sword CH Trainer
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to jammerlap
    ELITE
    jammerlap posted on Jul 26, 2007 4:58:16 AM - Report post
     
    Can't get the trainer to work with the mod "The Road to War". Tried to do as JGary321 mentioned in his post, but it still doesn't work. Can confirm that it works with the Nextwar-mod though.
  • Send a message to MaxieDude
    INACTIVE
    MaxieDude posted on Jul 26, 2007 5:08:03 AM - Report post
     
    I think there is others than me whom for which the game crashes when using f3.. but f1 and f2 are fine.. I just play as the russians in a normal campaign on continents.. chieftain diffeculty, I don't know what else to type about the game, all I know is, that the research function doesn't work for me.. (I play version 1.7.4, with no-cd crack..)
     
  • Send a message to voidster
    INACTIVE
    voidster posted on Jul 27, 2007 3:53:04 AM - Report post
     
    i must be doing something completly wrong, is the trainer for 3.0.0.91 or the latest one? i load the trainer then my game and the trainer says it cannot find the exe in ram, Yet the game runs fine. *scratches head* ill experiment with a no cd exe and see if that works.
     
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to mundo22
    ELITE
    mundo22 posted on Jul 27, 2007 12:03:15 PM - Report post
     
    im having the same issue man
  • Current rank: 3.5 Stars. Next Rank at 8000 Posts.
    Send a message to forty-two
    AUTHOR
    forty-two posted on Jul 27, 2007 12:21:55 PM - Report post
     
    One Turn Creation of Units, Buildings and Research, Unlimited Movement of Units. Made exclusively for Cheat Happens. WRITTEN FOR THE ORIGINAL (UNPATCHED) VERSION OF THE EXPANSION. ALSO INCLUDES A TRAINER FOR THE 1.7.4 PATCHED VERSION OF ORIGINAL GAME. May not work with all versions. Read the included readme file with Notepad for important instructions on using the trainer.

    /--\
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to ThunderWind
    ELITE
    ThunderWind posted on Jul 29, 2007 12:55:01 AM - Report post
     
    Look like Civilization 4, beyond the sword and warlords have got a new patch and any idea if trainer would be out for this patched ver?.
  • Founder
    Send a message to Caliber
    FOUNDER
    Caliber posted on Jul 29, 2007 6:34:07 AM - Report post
     
    ok i tested civilization beyond the sword with the russians, etc. and it seems to work perfectly. i cannot replicate any crashes in the game. the Civ IV trainer (not beyond the sword) did have some problems and i fixed it. here is the version i am playing with:


    at main menu:

    go to ADVANCED
    then select

    ABOUT THIS BUILD

    which shows:

    for Beyond the Sword my version is:
    3.0.0.91 (74697)

    and for Civ IV by itself my version is:
    1.7.4.0

    I am uploading the new trainer for CIV IV by itself to eliminate the crashes from before. Remember that you only run ONE trainer and you must run the correct trainer for the game you are playing (either CIV IV by itself or BEYOND THE SWORD by itself).

    If these trainers aren't working for you then likely something is interfering with the trainer writing to your game OR we have different versions.

    If there is a new version of the CIV IV or BEYOND THE SWORD out then i am not aware of it. what version is it. where do you get it? etc.

    best,
    Cal


    Pwiz will post the new version(s) shortly-



    [Edited by Caliber, 7/29/2007 6:40:40 AM]
    Trainer Creator
    www.cheathappens.com
  • Founder
    Send a message to Caliber
    FOUNDER
    Caliber posted on Jul 29, 2007 6:48:29 AM - Report post
     
    also just for information, most trainers are looking in memory for the game based on it's name. the name has to be exact.

    for these games, the name is:

    Civ4BeyondSword.exe

    and

    Civilization4.exe

    note that the capitalization must be exact and the spelling must be exact. sometimes updates or cracked versions of the game the .exe is named differently, etc. the trainer will not find

    civ4beyondsword.exe

    when it is looking for

    Civ4BeyondSword.exe

    etc. that is why you will get the "loading" blinking over and over if it hasn't found the right thing. the same thing can occur with a mod or a different version of the game that might have renamed a .dll in the game. the .dll

    CvGameCoreDLL.dll

    is important in this game and in this trainer. if it has been modified or if it has been renamed in some way

    (for instance cvGameCoredll.dll or CvGameCoreDLL.DLL) well you get the idea. the trainer won't work because the spelling and capitalization is important.

    maybe this might explain some probs. i cannot control these types of things!

    best,
    Cal
    Trainer Creator
    www.cheathappens.com
Page 4 of 7   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 5:58:05 AM