CoSMOS Gamehacking Tool
Page 1 of 3   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
VEH Debugger shows no results
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to CYER9
    MEMBER
    CYER9 posted on May 30, 2020 6:15:29 PM - Report post
     
    I am switching to CoSMOS Advanced after using cheat engine, and I'm trying to get the debugger to work, but it doesn't show any results. I'm using VEH btw. the weirdest part is it works on some games, but not others. It will occasionally work on a game once, then fail the next time. I tested the exact same address with cheat engine, (also using the VEH debugger, and I got the expected output). The log prints this error when using either find out option. (Couldn't get the thread context. Failed at SuspendThread with 0x5). It is the same error for every game it fails on. Any help would be appreciated because I am pretty new to CoSMOS, but I much prefer the GUI over CE.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to CYER9
    MEMBER
    CYER9 posted on May 31, 2020 4:30:34 AM - Report post
     
    Ok, I fixed it. But I don't know how

    [Edited by CYER9, 5/31/2020 4:30:43 AM]
  • Trainer Maker
    Send a message to 0x90
    STAFF
    0x90 posted on May 31, 2020 4:48:00 AM - Report post
     
    The log always prints this message because there might always be threads it cannot pause, i.e. system threads. CE silently ignores them. It is basically meaningless.

    Can you tell me a few games you have issues with so I can try to reproduce it?
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to CYER9
    MEMBER
    CYER9 posted on May 31, 2020 7:44:40 AM - Report post
     
    The two I had most consistent issues with were DOOM Eternal, and GTAV. (Yes both in offline I have some morals) but as I mentioned in my first post, it worked sometimes but not others. It worked on some address, not others, on some restarts of the game it worked perfectly, and on some, it didn't work at all/ That mainly why I made this post, the Inconsistency was baffling. A good example was I wanted Inf ammo to destroy the final sin fight. So the first time I tried, I found the address like normal, then used F6 to find out what writes to it. Shot a few times, no results. I was confused. So I opened CE, used the same address and attach the debugger. Right away a few instructions popped up. Then I closed CoSMOs and reopened it, because that is a miracle cure, to no Avail. so I restarted DOOM a couple of times with no luck, and then it just started working. (All using the ammo example, but I also tried other things). Even more confused I restarted both DOOM and CoSMOS and it didn't work. I tried uninstalling CoSMOS and replacing it with the contents of the zip file (the download) and that didn't seem to help NOTE. (All on 6.0.2 btw, it was working on earlier versions but I didnt use them much because I preferred CE's Lua support) I came back today, works fine through multiple testing. So no idea what happened. I couldn't find any recent thread on a similar topic either, so I figured it had to be a bug with the new release. Apparently computers are just funky sometimes. Thanks for your quick response though.

    PS. Another weird note, if I used the Disassembly viewer to NOP the address the CE VEH came up with it worked fine the whole time.

    [Edited by CYER9, 5/31/2020 7:49:07 AM]
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to CYER9
    MEMBER
    CYER9 posted on May 31, 2020 7:50:03 AM - Report post
     
    the weird NOTE tag in the middle is: "because it was showing no results again"
    I tried to edit it to this and got blocked for copyright so I am just adding a separate post to clarify.
  • Founder
    Send a message to PWizard
    FOUNDER
    PWizard posted on May 31, 2020 9:12:39 AM - Report post
     
    I just wanted to step in here and say that I appreciate you moving from CE to CoSMOS and providing us with valuable feedback so we can continue improving the product. If there are any missing features or anything else that you would like to see implemented that would help your transition, do let us know. Thanks!
    Chris O'Rorke (chris@cheathappens.com)
    Co-Founder: Cheat Happens.com

    Facebook . Vimeo . YouTube
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to CYER9
    MEMBER
    CYER9 posted on Jun 01, 2020 3:51:21 PM - Report post
     
    Thanks but I don't have enough experience with CoSMOS yet. There are a lot of features I just don't know how to use yet.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to CYER9
    MEMBER
    CYER9 posted on Jun 02, 2020 1:30:10 AM - Report post
     
    I do have some questions though:

    1: Is there a repository of addons or something similar? I know CE had a lot of unique add-ons that were put in the Autorun folder. I noticed a similar folder for CoSMOS.

    2: Is there a way to save my window configuration? (Like to the Layout.xml)

    3: Also the Test All scripts option for the cheat table shows an error about not being attached to a target process, even though it is. Once I hit OK it runs fine.

    4: How does the Solution Explorer work? I tried changing the directory in Options, but it still shows nothing.

    Thanks
Page 1 of 3   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 9:28:24 PM