Need for Speed: Most Wanted Message Board
Our Need for Speed: Most Wanted Trainer is now available and supports ORIGIN. Our Need for Speed: Most Wanted message board is available to provide feedback on our trainers or cheats.
Need for Speed: Most Wanted Trainer
REQUEST MORE OPTIONS
0 option(s) for voting
FILE UPDATE REQUEST
0 report(s) filed
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 1 of 1
Signup or Login to Post
Clarification please!
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to Erebus214
    SAGE
    Erebus214 posted on Dec 27, 2016 11:27:55 AM - Report post
     
    The trainers on both listings of Need For Speed Most Wanted are for the version of the NEW game released in 2012(Link). The one that this posting was supposed to be about was the one released in 2005. It was the follow up to Underground 2 (Link)

    They are two completely different games, just the same name, yet both only have trainers for the new one, released in 2012.

    I am just trying to get clarification, because you closed the old post where you said this was done on purpose, and that is all you said about it.

    Are the trainers cross compatible?

    What was the purpose, I think people would have less confusion with a little clarity, including me. lol
Page 1 of 1
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 7:49:23 AM