Age of Empires 3 Discussion

Age of Empires 3 Trainer

Trainer Tools and Resources

Request More Trainer Options for Age of Empires 3
0 option(s) for voting
File Trainer Update Request for Age of Empires 3
0 report(s) filed
Boost Trainer Update Priority for Age of Empires 3
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Pressing F1 to activate trainer problems
j2o1707  posted on Nov 13, 2014 5:52:48 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to j2o1707
Regarding the Trainer 1.12, Add Gold, Wood, Food, Export, Exper....

I downloaded the age 1.12 version, but it seems to crash when I press F1 and says Age of Empires 3 is not responding... Anyone else experience this or know of it?

I have the latest version of AoE3, it did work BEFORE I downloaded the updates. As in, when i pressed F1 on the default version of the game, it worked perfectly fine. (do not know if the trainer worked in_game, but it did say "trainer activated"

Any questions, please ask.

[Edited by j2o1707, 11/13/2014 6:15:52 PM]

Caliber  posted on Nov 14, 2014 3:54:01 PM - Report post

Send a message to Caliber
this game is from 2008. I don't own the disks or even have it installed anymore.. I have no suggestions as we don't have a way to look at this title 7 years later.
Page 1 of 1
  Post Reply
All times are (GMT -06:00) Central Time (US & Canada). Current time is 2:46:14 PM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Latest Trainer
Age of Empires 3 Trainer
• Add Gold
• Wood
• Food
+ 3 more options
  Show all Cheats & Trainers