Wolfenstein: The New Order Discussion

Wolfenstein: The New Order Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Trainer Update
0 report(s) filed
Boost Trainer Update Priority for Wolfenstein: The New Order
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 19 of 19   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
Official Trainer Thread  Wolfenstein: The New Order Trainer
salvatore28  posted on Dec 01, 2016 3:12:32 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to salvatore28
originally posted by PWizard

originally posted by salvatore28


just registered, so sorry if this has been already discussed before. The problem is related to the "New Order" trainer. I state in advance that I have centralized all of my games using D-Fend Reloaded and it works very well, with both old DOS games (emulation) and recent Windows games (they are simply launched without any emulation). Every game profile has a "Helper programs" section where you can specify one or more programs to be launched before or after the main game's executable (see "Old Blood profile.png" and "New Order profile.png" images). I use this mechanism to launch the trainer before the game:

Wolfenstein The Old Blood: the free CH trainer works fine, as expected
Wolfenstein The New Order: the purchased CH trainer fails to autenticate (see "Failed trainer.png" image)

For "Old Blood" I'm using a command line utility called "Elevate32.exe" that runs the trainer elevated, for "New Order" I'm simply running the trainer because it seems that it doesn't need to be run elevated.

But the same "New Order" trainer executed outside of D-Fend Reloaded works fine and authenticates regularly (see "Succeeded trainer.png" image).

It's not a so big problem, but I'd like to fix it if possible. In your opinion, is it something that can be fixed in the trainer or is it another problem not caused by the trainer?

Thank you

[Edited by salvatore28, 11/29/2016 6:40:01 AM]

We see this mostly when you have Windows Defender turned on or some type of firewall that doesn't allow the authentication to occur. You can try completely disabling Windows Defender, clear all caches (system, DNS, browser) and reboot. Then see if it works. If not, you can get an offline key from the trainer troubleshooting page and that might work. But your network/internet connection must be completely disabled/unplugged for the offline key to be read.


thank you very much for the reply. Let's see your reply point by point:

Windows Defender: It is already and always disabled (disabled by NOD32 when installed).

Windows Firewall is enabled.

But attention:

The trainer launched by D-Fend fails to authenticate
The trainer manually launched ouside D-Fend works just fine

So I would exclude the Windows firewall as well.

At this point I would say that it's something caused by D-Fend.

What do you think?


Hoover1979  posted on Jun 27, 2017 10:00:43 PM - Report post

Current rank: 1.5 Stars. Next Rank at 500 Posts.
Send a message to Hoover1979
My WTNO on Steam hasn't recieved an update in years. Is the update this trainer for only on the US version? I am in Australia and I think my last update was in 2015.
Loki  posted on Jun 28, 2017 10:09:37 AM - Report post

Premium Plus
Send a message to Loki
originally posted by Hoover1979

My WTNO on Steam hasn't recieved an update in years. Is the update this trainer for only on the US version? I am in Australia and I think my last update was in 2015.

Latest trainer works with the latest update just tested.



DGrant2561  posted on Dec 11, 2017 6:56:22 PM - Report post

Premium Plus
Send a message to DGrant2561
I just had this same thing happen to me as Zerbyte posted previously. All of a sudden the game started running in slow motion. I tried loading from the last checkpoint and it was still in slowmo. So, I shut down and restarted the trainer and game. Now when I try to resume, the game locks up. The error log has the same warning line as Zerbyte, along with a bunch of similar warning lines. I tried to find a previous save to start from but no joy. I went to my Machine Games saves but do not see a list anywhere to try. I am fine with loading a previous save, but I can't seem to do that either. I tried starting without the trainer on but it does not help. I will attach the error log.

[Edited by DGrant2561, 12/11/2017 6:56:52 PM]

CyPHeR369  posted on Dec 11, 2017 7:13:50 PM - Report post

Send a message to CyPHeR369
originally posted by Caliber

originally posted by Zerbyte

Got a crash bug caused by the trainer that won't let me resume from the checkpoint since it freezes the game. Anti-cheat thing maybe. Says
"WARNING: weaponupgrades/lkw_strobe is singular but count is 999"

Many many rows of that message.

Yes I turned off the trainer completely and tried several times just to be sure it was saved to file and not the trainer doing it.
Thought you should know.
Off to redo the entire chapter heh.

may be related to the ammo option, since it gives you 999 at all times. I haven't run into this problem here at all. perhaps just use the no reload option and leave the ammo option off it this is the problem you are having



Is this the post your talking about?

DGrant2561  posted on Dec 17, 2017 8:58:12 PM - Report post

Premium Plus
Send a message to DGrant2561
It is. I did find that I could load from a previous chapter start and that is what I ended up doing. Once I loaded from the previous chapter start, I was able to move on. Then, it happened again in the final fight. Once again, I went back and started the chapter again and was able to finish.
Page 19 of 19   •  First Page  •  Previous Page  •   Next Page  •   Last Page
  Post Reply
Go to page: 1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 5:34:58 AM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Game Review
Trainer Support
Having trouble getting our trainer to work? These steps resolve 99% of all trainer issues.
Temporarily disable/uninstall all antivirus,
firewall and other security software.
Right click and choose "Run as Administrator"
on trainer and game.
Make sure trainer version matches game
version and distribution.
Currently there are no reports of the latest trainer needing an update. File a Report.
  See the Trainer Troubleshooting Guide
  Getting an Anti-Virus Notification?
Latest Trainer
Wolfenstein: The New Order Trainer
• No Damage
• Super Ammo
• No Reload
+ 10 more options
  Show all Cheats & Trainers
Latest Wallpaper
1024 x 768
1152 x 600
1280 x 960
1280 x 1024
1600 x 1200
1920 x 1200
Wallpaper #1 of 4   Show All