Planet Explorers Message Board  STATUS: ACTIVE - Trainers are still being considered and updated for this title as patches are released. There is no guarantee that a trainer can be made or updated but it will be reviewed by our staff.

Our Planet Explorers Trainer is now available for version 1.1.3 and supports STEAM. Our Planet Explorers message board is available to provide feedback on our trainers or cheats.
Planet Explorers Trainer
REQUEST MORE OPTIONS
0 option(s) for voting
FILE UPDATE REQUEST
0 report(s) filed
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 19 of 25   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
  Planet Explorers Trainer
  • Trainer Maker
    Send a message to 0x90
    STAFF
    0x90 posted on May 22, 2015 10:11:44 AM - Report post
     
    Then I don't know. But access denied is not caused by a game update. It's caused by either something is blocking the trainer (I cannot tell because I don't sit in front of your computer) or by having not enough rights to access to the game's memory (I cannot tell either over distance).
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to JamesJB40
    VETERAN
    JamesJB40 posted on May 22, 2015 8:24:36 PM - Report post
     
    Well I did get it to work BUT I have to Login to the computer as Admin on the Admin Account,which I really don't want to do all the time.

    I mainly use the Admin account to do maintenance and other admin stuff only.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to bandai380
    ELITE
    bandai380 posted on Jun 28, 2015 8:15:49 AM - Report post
     
    The game just updated to A0.88, can we get an update for this trainer please?
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to bandai380
    ELITE
    bandai380 posted on Jun 29, 2015 4:42:20 PM - Report post
     
    We have another updated to A0.8821, the trainer does not work anymore.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to spazzer
    ELITE
    spazzer posted on Jul 10, 2015 1:07:34 AM - Report post
     
    Can confirm trainer still works on my current version. I use default settings, the launcher lists "Current version: Alpha 0.871", "Latest Version: Alpha 0.86"

    Either way, the trainer still works. I tried the hotkeys as well as the editor.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to bandai380
    ELITE
    bandai380 posted on Jul 15, 2015 7:31:17 AM - Report post
     
    For me the trainer d'ont works.
    "Curent verson: Alpha 0.883"
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to Tiberiumkyle
    ELITE
    Tiberiumkyle posted on Sep 21, 2015 9:24:39 PM - Report post
     
    PE trainer works for stable steam build, which is .871 or such. The Opt-in beta branch is the version the trainer isn't working for, likely due to major changes the devs continue to make on that branch.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to Ocnuybear
    ELITE
    Ocnuybear posted on Dec 08, 2015 11:20:06 AM - Report post
     
    Current trainer not working, please update to version 0.89.
Page 19 of 25   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 4:09:06 AM