Rogue Legacy Message Board
Our Rogue Legacy Trainer is now available and supports STEAM. Our Rogue Legacy message board is available to provide feedback on our trainers or cheats.
Rogue Legacy Trainer
REQUEST MORE OPTIONS
0 option(s) for voting
FILE UPDATE REQUEST
report(s) file
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 6 of 11   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
  Rogue Legacy Trainer
  • Current rank: 2.5 Stars. Next Rank at 2000 Posts.
    Send a message to madatcheats
    ELDER
    madatcheats posted on Jul 03, 2013 6:21:13 AM - Report post
     
    I've only tried to edit the money with CE. It works (simple 4bytes value)but the game changes addresses every time you leave a room. That in mind it takes only 20 seconds to get infinite money.
    Better to reign in hell, than to serve in heaven.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to hellfyredrgn
    ELDER
    hellfyredrgn posted on Jul 03, 2013 5:07:34 PM - Report post
     
    Just to let you guys know, this modified EXE on the fly garbage is annoying me to all hell. I've used both the Humble Bundle and Steam versions (Steam first), which seem to be the exact same game, just with a different distribution method. I've got the right trainer versions, i've done everything possible to get the trainer to work, and it just won't. There seems to be some instances of the game's code being too different from the trainer and crashing the game instantly on hitting F1. Good news is the Editor STILL works in 1.0.11. I've been able to adjust the values i wanted to mess with using that. I'm also running Windows 8.1 Beta, and have noticed that the trainers work fine across 8/8.1 with no adjustment on my end. if you don't have 8.1 yet, and you have someone bug out with a trainer in 8.1, let me know, and I'll do my best to test the trainer/game and see if there's something that i can help with
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to Zerbyte
    ELITE
    Zerbyte posted on Jul 06, 2013 5:00:03 PM - Report post
     
    They patched again. But doesnt seem to effect the trainer besides longer time to find the numbers.

    Patch v1.0.12 is Available
    Patch Notes v1.0.12
    ————————————————————————————————-

    Major Changes:
    - Added support for DirectInput controllers (toggle-able from options screen).
    - Alexander will now spawn higher level mobs on NG+ and above.
    - All bosses now break Paladin secret move, not just the final boss.
    - Fixed bug where controller hardware was being polled too often, resulting in significant lag for some systems.

    General fixes:
    - Optimization tweaks to rendering. People should find a small improvement to framerate.
    - Typo fixes to profile card crit chance.
    - Fix to game sometimes crashing during Alexander fight.
    - Fixed bug where beating the game with Calypso’s compass would crash the game.
    - Fixed bug where architect fee could carry over to NG+
    - Fixed bug with architect fee text overlap on NG+ bonus.
    - Typo fixes in Journal, and Paladin, and Translocator spell description.
    - Alexander boss floor and roof lowered to prevent him from going too low.
    - Enemies that are split during timestop are now immune to timestop until it’s reactivated (Feature).
    - Enlarged projectile pool.

    Balance Changes:
    - Architect fee raised from 30% to 40%.

    [Edited by Zerbyte, 7/7/2013 7:58:58 PM]

  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to JasperPD
    ELITE
    JasperPD posted on Jul 14, 2013 2:57:37 PM - Report post
     
    Everytime I attempt to use the trainer it activates but when I press any key it shoots back, "Trainer Cannot Find Game." I'm doing exactly as I'm supposed to, start trainer first, press F1, then in game activate options, it is the same trainer version to game version.
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to snowpin
    ELITE
    snowpin posted on Jul 30, 2013 4:16:54 PM - Report post
     
    they updated again, that could be why it doesn't work.

    Rogue Legacy v1.0.13

    Major Changes:
    - Implemented some non-trivial optimizations to increase game performance.
    (Smarter sprite batching)
    (Merged several spritesheets to reduce texture swapping)
    (Additional minor tweaks to reduce GPU load).
    - Fixed bug where corrupt backup saves would get players into endless save corruption loops.
    - Forced flushing to OS stream for backup files to (hopefully) reduce the chances of a backup save corrupting.

    General fixes:
    - Fixed bug where gold would very rarely go into the negatives, resulting in a crash.
    - Removed normal mapping effects from the content pipeline.
    - Fixed bug where you could exit the axe carnival room, resulting in odd game behaviour.
    - Fixed bug where you could talk to shop keeps and architect while in mid-dash, resulting in a crash.
    - Fixed bug where beating the last boss would zero out your traits.
    - Fixed bug where money bags were not animating properly upon landing.
    - Fixed bug where beating the game with the compass item would result in a crash when starting a new game.

  • Current rank: 1.5 Stars. Next Rank at 500 Posts.
    Send a message to CallofPCgamer
    SAGE
    CallofPCgamer posted on Aug 24, 2013 9:39:23 AM - Report post
     
    So when will there be new update
    Mate...
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to zachofragnarok
    ELITE
    zachofragnarok posted on Aug 28, 2013 5:45:49 PM - Report post
     
    So tried the trainer today, got the newest updated one, ran it as administrator before running the game (steam version), pressed f1 at the main screen, got activated, made sure I was in game so the "elements that are edited are visible" I believe is how it went, activated magic. Finds it and activates, works with infinity mana, great! Try the add gold one, does the "cannot find game............ activated" then press it again, and it does that process again, seems to not add gold. Not sure how to fix that but not a big deal for me.

    The thing I'm not understanding is "ultimate damage". I turn that on, with the game paused no less, it does the "cannot find game.....activated" the first time, then press it again and it just says "activated". Unfortunately I take damage like normal and I don't have increased damage in case I misunderstood the point.

    TL;DR How can I get the "unlimited damage" i.e. infinite health part of the trainer to activate in a steam retail version of the game? And also as a side note, is there a certain place you have to activate the trainer to get the "add gold" to work as well? Thanks in advance!

  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to Leishu
    ELITE
    Leishu posted on Sep 01, 2013 11:58:31 AM - Report post
     
    Well... it's been a month+ since the game updated. Any word on getting a working version of this trainer up? Pretty please?
Page 6 of 11   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 1:06:21 AM