Rogue Legacy Discussion

Rogue Legacy Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Update
report(s) filed
Boost Trainer Update Priority for Rogue Legacy
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 3 of 11   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
Official Trainer Thread  Rogue Legacy Trainer
Victory  posted on Jun 30, 2013 7:08:59 AM - Report post

Current rank: 1.5 Stars. Next Rank at 500 Posts.
Send a message to Victory
I don't know about him, but it works for me 0x90, Great job again .
DJAlucard  posted on Jun 30, 2013 10:00:40 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to DJAlucard
originally posted by 0x90

Does the trainer says it cannot find the code for gold? Also check the console on the trainer for any entry about that. If not then it should work. It adds gold ingame to your character. Not sure about 'pool or family gold'. Don't even know what you mean.

Trainer activates fine, meant the pool of family gold, as your heirs keep your gold when you die, I'll try checking the console see whats happening when i try to add more gold!

so ran it again, everything seems fine Console shows "<09:08:15> [PROCESS]: Found RogueLegacy
<09:08:27> [TRAINER]: Activating...
<09:08:27> [PROCESS]: HASH: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
<09:08:27> [PROCESS]: Version:
<09:08:27> [PROCESS]: Version(2):
<09:09:00> [TRAINER]: Successfully activated" but still wont give me more gold!?

[Edited by DJAlucard, 6/30/2013 10:11:46 AM]

lordcook  posted on Jun 30, 2013 11:12:54 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to lordcook
Not working for me either, except my game is v1.0.10a (steam) but I cant find mention of an update.
LordJB  posted on Jun 30, 2013 1:48:09 PM - Report post

Current rank: 2 Stars. Next Rank at 1000 Posts.
Send a message to LordJB

Patch 1.0.10 Bug/Balance Fixes:

Major Changes:
- Back up saving Re-enabled. If your data gets corrupted (from power outtage or something), the game will load up a back-up save.
- Game will announce an error if it cannot save a file 3 times.
- People from Turkey can now play the game.

General fixes:
- Numpad now configurable in key bindings list.
- Trait Tourettes changed to Coprolalia
- Typo fix for Alektorophobia.
- Fixed exploit with invulnerable assassin.
- Fixed bug where saves no longer worked if you ran game with an argument passed in the command line.
- Fixed bug where Special class could lose their special spell.
- Fixed Boss sfx not being adjusted by SFX volume settings.
- Fixed carnival exploit with special class.
- Fixed Final boss fight making player clip through wall during cutscene in special places.
- Fixed special class having no spell delay.
- Fixed exploit with Barbarian special destroying all targets in carnival room.
- Fixed bug where game would sometimes crash when exiting outside entrance.
- Dragon armor bug fix. Armor raised from 68 to 78.
- Last boss drops 1 less mana pot.
- NG+ Difficulty raised slightly.
- NG++ Difficulty raised significantly.
- Down Strike Up text updated.
- Mage INT bonus reduced from 1.35x to 1.3x
- Fix 1×2 map with barrels letting player jump out of the world.
- Fix 2×3 map block spawn bug.
- Typo fixes in skill tree (assassin, miner, etc)
- Time stop mana drain tic rate raised from 7 to 8.
- Red teleporter random crash bug fixed.
- Fixed bug where Ice and Fire wizarsd projectiles would die in their hands if you ran into them.
- Dying death crash bug fixed.
- Fixed bug where game wouldn’t load properly if Game Config was empty.
- Security check to make sure game doesn’t run on RunGameOver
- Fixed bug where potion up and downstrike up descriptions were not updating properly.
- Min mana and health capped at 1. You can no longer go into the negatives.
- Fixed bug where hazards could deal 0 in special circumstances.
- Fixed bug with projectiles sometimes being fired backwards.
- Fixed bug where equipping blood equipment would screw up HUD in blacksmoith screen.
- Fixed bug with last boss where you could take damage if you were in a bad position when you beat him.
- Fixed bug with Last boss and time stop.
- Disabled all Class Skills in carnival room.
- Fixed bug with mana loss appearing if crowstorm was cast in an empty room.
- Dwarf holes removed in 2×2 room.

Patch 1.0.10a Bug/Balance Fixes:

Major Changes:
- Fix to backup saves to resolve issue with people crashing at start.

General fixes:
- Fixed game crashing sometimes on level load.
- Fixed Rhabdophilia achievement being earned at level start.

There, that's the changelog for today's 1.0.10 update and the 1.0.10a hotfix.

Scavar  posted on Jun 30, 2013 10:58:20 PM - Report post

Premium Plus
Send a message to Scavar
So I have no idea what's going wrong for me, as normal I've tried everything in reference to AV/Firewall/Admin and so on. My game version 1.0.9 and according to the console log it works. I start the trainer, go into the game and press F1. I hear the first Trainer Activated and I wait for the second, but it never says it again unless I hit one of the cheat keys. When I do that it says it again, but then I get the error message about checking the console log, when I close that I hear trainer activated another two times. As you can see in the log it appears to be working//twice in a row? Yet it isn't -_-

Thanks for all your work though.

<23:53:23> [PROCESS]: Found RogueLegacy
<23:53:30> [TRAINER]: Activating...
<23:53:31> [PROCESS]: HASH: B017311ECC27CC2725E6BF1F0CD736D1
<23:53:31> [PROCESS]: Version:
<23:53:31> [PROCESS]: Version(2):
<23:54:02> [TRAINER]: Activating...
<23:54:02> [PROCESS]: HASH: B017311ECC27CC2725E6BF1F0CD736D1
<23:54:02> [PROCESS]: Version:
<23:54:02> [PROCESS]: Version(2):
<23:54:03> [TRAINER]: Successfully activated
<23:54:14> [TRAINER]: Successfully activated

armin2000  posted on Jul 01, 2013 3:19:57 AM - Report post

Current rank: 1.5 Stars. Next Rank at 500 Posts.
Send a message to armin2000
Thanks PWizard and 0x90 this trainer work for me so fine
empirebattles  posted on Jul 01, 2013 9:21:18 AM - Report post

Premium Plus
Send a message to empirebattles
This was working, until the game decided to update to 1.0.1 (on steam). Now it just gives an error saying that it cannot find the game code (after the first 'activated')
0x90  posted on Jul 01, 2013 10:06:44 AM - Report post

Trainer Maker
Send a message to 0x90
I would need access to your system where the game is running to see what's different. The trainer is working on my end and also for some other people. Sadly the game code is different from system to system and created on the fly, that means an executable only wouldn't help.

If you don't mind, send me a PM and I'll try to get it working for you.

[Edited by 0x90, 7/1/2013 10:07:00 AM]

Page 3 of 11   •  First Page  •  Previous Page  •   Next Page  •   Last Page
  Post Reply
Go to page: 1  2  3  4  5  6  7  8  9  10  11 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 3:45:18 AM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Game Review
Trainer Support
Having trouble getting our trainer to work? These steps resolve 99% of all trainer issues.
Temporarily disable/uninstall all antivirus,
firewall and other security software.
Right click and choose "Run as Administrator"
on trainer and game.
Make sure trainer version matches game
version and distribution.
This title has been marked as RETIRED and is no longer supported or being updated.
  See the Trainer Troubleshooting Guide
  Getting an Anti-Virus Notification?
Latest Trainer
Rogue Legacy Trainer
• Unlimited Damage
• Mana
• Super Strength
+ 3 more options
  Show all Cheats & Trainers