Kerbal Space Program Discussion

Kerbal Space Program Trainer

Trainer Tools and Resources

Request More Trainer Options
0 option(s) for voting
Request Trainer Update
0 report(s) filed
Boost Trainer Update Priority for Kerbal Space Program
Boost currently not available

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 5 of 9   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
Official Trainer Thread  Kerbal Space Program Trainer
jshields1986  posted on Oct 23, 2013 12:03:19 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to jshields1986
the .net framework error is caused when you activate it incorrectly, go launch a rocket and before actually launching one press f1 and you should hear the activated sound 2 times.

however this still doesnt resolve the science points issue.

0x90  posted on Oct 23, 2013 1:20:36 PM - Report post

Trainer Maker
Send a message to 0x90
The science points should be fixed, make sure you've downloaded the latest trainer (again).
sirged  posted on Oct 25, 2013 10:33:19 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to sirged
I get a .net exception when pressing 3 for science points as well. I was sure to wait until I was on the launch pad and toggled warp a few times to make sure. I have not used any previous versions of the trainer.
0x90  posted on Oct 25, 2013 10:59:14 AM - Report post

Trainer Maker
Send a message to 0x90
There are TWO ways you need to take of:

1. The normal activation by pressing F1 (see notes)
2. The option 3 (has it's own 'activation', see notes)

If you activate the trainer successful and press numpad 3 right after it will fail.

sirged  posted on Oct 25, 2013 9:49:03 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to sirged
The trainer never activates. As soon as I hit F1 to activate it fails. I first start the trainer, then I start the game (I've tried through steam and without) then go to my launchpad. Make sure it is fully loaded. Cycle timewarp once. Then I press F1 to activate the trainer. It says "Trainer Activated" only once, then locks up and throws the .net error.

I get the same on my desktop or my laptop.

*Edit for clarity*

[Edited by sirged, 10/26/2013 1:16:51 PM]

0x90  posted on Oct 26, 2013 2:54:08 AM - Report post

Trainer Maker
Send a message to 0x90
So you hit F1 to activate AFTER starting the trainer and THEN start the game? That's the wrong way. You have to go to your launchpad ingame first, change the timewrap once and THEN press the F1 key.

Or do I misunderstood something?

sirged  posted on Oct 26, 2013 1:17:08 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to sirged
Edited above post for clarity
Boris911  posted on Oct 29, 2013 3:03:41 AM - Report post

Premium Plus
Send a message to Boris911
Hello, I have problem with KERBAL SPACE PROGRAM TRAINER . After activation the trainer freeze and fall down. It is on Windows 8.1 Professional x64 and Windows 7 Ultimate SP1 x64, too what I tried. Both was clear installation of operation system with Office 2013 and with all updates from Windows Update.

Detail of this error message is:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.OverflowException: Arithmetic operation resulted in an overflow.
at KerbalSpaceProgramm_CH.MemoryEditor.Memory.ReadComplete(Int64 iMemoryAddress, Byte[] valbuffer)
at KerbalSpaceProgramm_CH.MemoryEditor.Memory.AOBSCAN(Int32 baseAddress, String sig)
at KerbalSpaceProgramm_CH.Form1.ActivateTrainer()
at KerbalSpaceProgramm_CH.Form1.tHotkeys_Tick(Object sender, EventArgs e)
at System.Windows.Forms.Timer.OnTick(EventArgs e)
at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 2.0.50727.5472 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
Assembly Version:
Win32 Version:
CodeBase: file:///C:/Users/Boris911/AppData/Local/Temp/~Mnn133.tmp
Assembly Version:
Win32 Version: 8.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/
Assembly Version:
Win32 Version: 2.0.50727.5467 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/
Assembly Version:
Win32 Version: 2.0.50727.5468 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/
Assembly Version:
Win32 Version: 2.0.50727.5467 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/
Assembly Version:
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/
Assembly Version:
Win32 Version: 2.0.50727.5476 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/
Assembly Version:
Win32 Version: 2.0.50727.5476 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

I thank you very much before for resolve this critical error.

[Edited by Boris911, 10/29/2013 3:07:16 AM]

Page 5 of 9   •  First Page  •  Previous Page  •   Next Page  •   Last Page
  Post Reply
Go to page: 1  2  3  4  5  6  7  8  9 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 6:54:06 AM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Game Review
Trainer Support
Having trouble getting our trainer to work? These steps resolve 99% of all trainer issues.
Temporarily disable/uninstall all antivirus,
firewall and other security software.
Right click and choose "Run as Administrator"
on trainer and game.
Make sure trainer version matches game
version and distribution.
Currently there are no reports of the latest trainer needing an update. File a Report.
  See the Trainer Troubleshooting Guide
  Getting an Anti-Virus Notification?
Latest Trainer
Kerbal Space Program Trainer
• Enable Cheat Menu (+17 options)
  Show all Cheats & Trainers