Feedback, Complaints or Problems

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Locked Topic  Stuck at 'Authenticating Trainer'
Merkar  posted on Feb 01, 2013 10:21:40 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Merkar
I recently downloaded the trainer of Crusader Kings II 1.91. When I tried to run it, it got stuck at authenticating trainer, followed by freezing and crashing.

Now all my trainers are not working. I've tried to solve the problem by getting an offline key. The trainers don't seem to recognize the key as they still try to authenticate. I then downloaded your trainer manager, registered it, but still have the same problem.

I also checked my subscription which is still under a lifetime status.

When I downloaded the CK2 trainer I had my VPN on (I'm in China atm and don't fancy censorship). I had forgotten to switch it off and have since then tried to access the trainer with my actual IP. I've been using your service for years and it's the first time this happened.

Did your security system kicked in? I'd appreciate if you could fix this.

PWizard  posted on Feb 01, 2013 3:30:09 PM - Report post

Send a message to PWizard
Completely uninstall VPN software, roll back to previous system restore. Some VPN software creates settings on your PC that are not supported by our trainers. You may have to format and reinstall Windows in order to fix it if you cannot remove the changes that were made by the software.
PWizard  posted on Feb 01, 2013 3:35:03 PM - Report post

Send a message to PWizard
more info:


Merkar  posted on Feb 01, 2013 9:56:33 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Merkar
Thanks for the reply, Chris.

I have been using an industry leading VPN for about a year now and that didn't cause issues with trainers before.

System restore is another good recommendation. Unfortunately this wasn't working since I replaced the HDD of my C: drive. When I added a bigger hard disk (after cloning the previous content from my old disk) it seems that Microsoft didn't bother to have system restore detect such changes. Basically system restore was pointing to a no longer existing C: drive from my previous HDD, and no restore was being done since then (I'm using Win7 x64).

Anyway, the trainers still work if I momentarily disable my NIC in order to allow the offline key to kick in. I've added a shortcut of 'Local Area Connection' to the desktop and I don't mind the extra step as long as it works.


[Edited by Merkar, 2/1/2013 9:57:37 PM]

Page 1 of 1
  Post Reply
All times are (GMT -06:00) Central Time (US & Canada). Current time is 1:08:48 PM
Cheat Happens Premium
* Access PC trainers and exclusive content
* Updated game trainers and cheats daily
* Get notified when new cheats are added
* Request which games get new trainers
* Priority support with any problem
Message Board Moderators
Important Board Topics
Trending Topics