Mass Effect 3 Message Board
Our Mass Effect 3 Trainer is now available for version 06.28.2020 and supports STEAM, ORIGIN. Our Mass Effect 3 message board is available to provide feedback on our trainers or cheats.
Mass Effect 3 Trainer
REQUEST MORE OPTIONS
0 option(s) for voting
FILE UPDATE REQUEST
0 report(s) filed
BOOST UPDATE PRIORITY
Boost currently not available
Message Board for PC version
Page 83 of 91   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
  Mass Effect 3 Trainer
  • Current rank: 3 Stars. Next Rank at 4000 Posts.
    Send a message to B4Marc
    BLANDUS COR
    B4Marc posted on Apr 22, 2015 1:50:56 AM - Report post
     
    quote:
    originally posted by egoeimai

    Hi,

    I am replaying the game now and I need the version 1.1.5427.4 trainer (haven't updated the game to the latest patches). However, your trainer for this version crashes upon opening it and at the bottom left side it's saying authenticating trainer.

    Can you please tell me what's going on? I downloaded the trainer for version 1.5 of the game and it runs fine. Can you please advise?

    Thanks guys and keep up the good work.


    It's usually the version of browser you're using, older trainers need older browsers

    Freedom is doing what we enjoy, happiness is enjoying what we do.

    La liberté c'est faire ce que l'on aime, le bonheur c'est aimer ce que l'on fait.


    Happy pc gamer
    Joyeux pc luron
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to egoeimai
    ELITE
    egoeimai posted on Apr 22, 2015 10:55:37 AM - Report post
     
    Thanks for the response B4Marc but I am a bit confused. What has the browser version got to do with the trainer? I have older CH trainers that require authantication and they work just fine!

    This used to work on my old PC and the only difference a year ago is that the OS system was Win7 32-bit while my current one is 64-bit. If the browser is the cause, what do I need to do?

    Are the developers seeing this or is there another way to get in touch with them for some support?

    Thanks again

    [Edited by egoeimai, 4/22/2015 10:58:05 AM]
  • Premium Plus
    Send a message to Jaks
    SPEC OPS
    Jaks posted on Apr 22, 2015 11:48:05 AM - Report post
     
    quote:
    originally posted by egoeimai

    Hi,

    I am replaying the game now and I need the version 1.1.5427.4 trainer (haven't updated the game to the latest patches). However, your trainer for this version crashes upon opening it and at the bottom left side it's saying authenticating trainer.

    Can you please tell me what's going on? I downloaded the trainer for version 1.5 of the game and it runs fine. Can you please advise?

    Thanks guys and keep up the good work.


    The last trainer update was 2013. You said you dloaded a trainer that is working ... why not use that one?

    Intel I9-9900K 5.0 GHz & Eisbaer 360MM Liquid Cooler
    NVIDIA RTX--2080 SUPER 8GB
    32GB Extreme DDR4 RAM -- 500GB SSD - 2TB SSD - 2TB WD Black HDD
    Seasonic FOCUS PLUS 850W GOLD PS
    FTM: Faster Than Me
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to egoeimai
    ELITE
    egoeimai posted on Apr 24, 2015 11:04:36 AM - Report post
     
    Hi Element5,

    This is what I did anyway. I just hoped that I wouldn't have to go through downloading the patches for the game as I wouldn't like to risk loosing my progress and saved files but I did it anyway and now I can use a trainer that is working.

    Thanks again
  • Current rank: 1.5 Stars. Next Rank at 500 Posts.
    Send a message to a_beast33
    ELITE
    a_beast33 posted on Jun 18, 2015 2:15:45 AM - Report post
     
    running trainer 1.4.5427.111 and it crashes the game, the game is patched to 1,4,5427,111.

    have removed AV, rebooted, re-installed game but am out of ideas.

    running win8.1

    any ideas please.

    many thanks
  • Premium Plus
    Send a message to ServiusTheBear
    MODERATOR
    ServiusTheBear posted on Jun 18, 2015 2:43:36 AM - Report post
     
    quote:
    originally posted by a_beast33

    running trainer 1.4.5427.111 and it crashes the game, the game is patched to 1,4,5427,111.

    have removed AV, rebooted, re-installed game but am out of ideas.

    running win8.1

    any ideas please.

    many thanks

    Try runing the game n the dlp n the trainer in Admin mode.

    My Site - www.serviusthebear.webs.com
    Steam - www.steamcommunity.com/id/ServiusTheBear
    Youtube - www.youtube.com/c/serviusthebear
    Twitch - www.twitch.tv/serviusthebear
    Facebook - www.facebook.com/ServiusTheBearTV
  • Current rank: 1.5 Stars. Next Rank at 500 Posts.
    Send a message to a_beast33
    ELITE
    a_beast33 posted on Jun 18, 2015 3:11:43 AM - Report post
     
    ahh yes forgot to mention ive tried running trainer as administrator, still causes the game to crash
  • Current rank: 1 Star. Next Rank at 100 Posts.
    Send a message to Adeptus_Astarte
    ELITE
    Adeptus_Astarte posted on Jan 22, 2016 12:05:09 PM - Report post
     
    Hey guys thought I'd have another playthrough of ME3 for fun and I've downloaded the top trainer, installed the game through origin and zilch. Everytime I run the game and the trainer it crashes. I've added exceptions to my firewall and AV software, run in administrator, tried alt tabbing and nothing works.

    I've tried a previous version of the trainer and that doesnt work (not surprised) any tips or word of a new trainer incoming?
Page 83 of 91   •  First Page  •  Previous Page  •   Next Page  •   Last Page
Signup or Login to Post
All times are (GMT -06:00) Central Time (US & Canada). Current time is 1:03:32 AM