LOGIN  .  SIGNUP   .  SUPPORT 
HOME / PC CHEATS & TRAINERS / STAR WARS: KNIGHTS OF THE OLD REPUBLIC 2 / MESSAGE BOARD / TELOS ACADEMY BUG NOT (CHEAT NODE)

Star Wars: Knights of the Old Republic 2 Cheats

 
Star Wars: Knights of the Old Republic 2 Trainer, Cheats for PC
 

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Telos Academy bug not (cheat node)
 
I_am_Nihilus  posted on Mar 10, 2010 7:19:59 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to I_am_Nihilus
ELITE
I seem to have encountered a previously unseen breed of the Telos bug, in which the PC is imprisoned on the Telos academy. My situation is similar to this, with some differences:

* When I enter the academy, no matter what dialogue options I choose, the "Give us your weapons" conversation ends with a black screen.
* Saving the game and loading that save game fixes the black screen problem. It spawns me near Atris' chamber, with Atris standing outside.
* I have to go up to Atris and talk to her to trigger the pre-set conversation.
* Everything proceeds as normal, Handmaidens escort me away, etc.
* At this point none of the Handmaidens except Brianna talk to me. No other NPC's will engage in conversation with me except T3 and Brianna.
* The pre-set conversations with Kreia, Atton and Bao-Dur do not trigger. The one with T3 does trigger, but it is as if starting a conversation with him on the Ebon Hawk. All of them are in their cages and don't move from there.
* Worst of all, the Ebon Hawk is unable to be entered. Nothing happens when I run into the ramp.

I am certain this is not a previously-encountered bug, so it warrants its own thread. How can I fix it, or at least force the game to trigger the proper ways? Is there a command that will just teleport me straight into the Ebon Hawk? oh and if some one with modding skills could maybe just make a skip telos academy mod that would be great. P.S the only mods i have are skip peragus and skip citidel station and could the patches cause this???

[Edited by master111, 3/10/2010 7:23:09 PM]

 
TiberiousKirk  posted on Mar 12, 2010 4:44:38 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to TiberiousKirk
ELITE
I think I had a similar bug once. I think I had to go back to a save prior to Telos Academy or restart the game. I can't remember which. It was quite a while ago.
I just remember that I talked to Atris three or four times and the game at the end of the next cut scene would put me back at the point I had to talk to Atris again and it just kept looping.
Sorry I can't help more.
 
I_am_Nihilus  posted on Mar 23, 2010 2:52:54 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to I_am_Nihilus
ELITE
Ok i fixed it myself its working fine now i just installed the TSLCRM restoration mod it fixes all the bugs i now get a bugg free game its 1.5 final release.

[Edited by I_am_Nihilus, 3/23/2010 2:53:28 PM]

Page 1 of 1
  Post Reply
 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 4:55:27 PM
CoSMOS Gamehacking Tool
  
Introducing Cheat Happens CoSMOS, a brand new self-service gamehacking tool designed for absolute beginners and advanced users alike. CoSMOS makes it easy and fun to hack your own PC games while waiting for our programming team to release new and updated trainers.

Featuring in-app tutorials, plenty of video demos, download CoSMOS today and start enhancing your favorite games in minutes.

Latest Trainer
• Add Credits
• Infinite Health
• Add EXP
+ 4 more options
  Show all Cheats & Trainers
Latest Wallpaper
1024 x 768
1152 x 600
1280 x 960
1280 x 1024
1600 x 1200
1920 x 1200
Wallpaper #1 of 6   Show All