LOGIN  .  SIGNUP   .  SUPPORT 
HOME / PC CHEATS & TRAINERS / WITCHER, THE (ENHANCED) / MESSAGE BOARD / WHICH PATCH DO I NEED?

Witcher, The (Enhanced)

Witcher, The (Enhanced) Trainer, Cheats for PC

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Which patch do I need?
 
XanoPhobious  posted on Oct 31, 2009 6:00:20 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to XanoPhobious
ELITE
I'm confused as to which patch 1.5 should I download...

I already have The Witchcer Enhanced Edition Installed, up to 1.4.5.1303, the EAX fix

Now, if I want to patch my game to 1.5...which patch do I need because it seems that there are more than one:

There is "The Witcher 1.5 Patch", is this for the enhanced edition or the original The Witcher?

and then there is "The Witcher: Enhanced Edition Director's Cut Patch" but I think this is for the censored version (North American), and mine is not censored

Please help...

Page 1 of 1
  Post Reply
 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 12:36:10 PM
Promo Codes
Latest Trainer
• Unlimited Health
• Endurance
• No Toxicity
+ 7 more options
  Show all Cheats & Trainers