LOGIN  .  SIGNUP   .  SUPPORT 
HOME / PC CHEATS & TRAINERS / STARSHIP TROOPERS / MESSAGE BOARD / CANNOT PLAY EVEN AFTER PATCHING

Starship Troopers

Message Board for PC version

Signup   Message Boards Home   Newest Posts   My Favorite Boards   My Threads
Page 1 of 1
Signup or Login to Post
Cannot play even after patching
 
Biddy2381  posted on Feb 18, 2014 3:33:04 PM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to Biddy2381
CHEATMASTER
Hi, I have been searching sooooo long for a solution to my problem and this is the most recent active post on any website about this game.

I recently installed my disc copy of Starship Troopers Terran Ascendancy on my latest pc!!!!

Amazing,,,right lol!

The problem I am having is that even after downloading the NVidia patch and full exe patch, I still cant get past the main menu.

The patches helped to start the game, the intro videos work perfectly but the main menu screen is not fully shown, I cant see any menu buttons or anything.

My system specs are:

Win 7 home Premium 64 bit
Intel i5-4670k at 3.40GHz
Nvidia Geforce GTX 770
16 GB RAM

My drivers are all up to date and current.

Can anybody please please please help me with this, I need t get it working again!

[Edited by Biddy2381, 2/18/2014 3:37:51 PM]

 
gere  posted on Apr 03, 2014 7:13:58 AM - Report post

Current rank: 1 Star. Next Rank at 100 Posts.
Send a message to gere
ELITE
quote:
originally posted by Biddy2381

Hi, I have been searching sooooo long for a solution to my problem and this is the most recent active post on any website about this game.

I recently installed my disc copy of Starship Troopers Terran Ascendancy on my latest pc!!!!

Amazing,,,right lol!

The problem I am having is that even after downloading the NVidia patch and full exe patch, I still cant get past the main menu.

The patches helped to start the game, the intro videos work perfectly but the main menu screen is not fully shown, I cant see any menu buttons or anything.

My system specs are:

Win 7 home Premium 64 bit
Intel i5-4670k at 3.40GHz
Nvidia Geforce GTX 770
16 GB RAM

My drivers are all up to date and current.

Can anybody please please please help me with this, I need t get it working again!

[Edited by Biddy2381, 2/18/2014 3:37:51 PM]

Are you still having issues Biddy? The problem is your Nvidia card, but there is a solution as well. Let me know if you still want help

Page 1 of 1
  Post Reply
 
All times are (GMT -06:00) Central Time (US & Canada). Current time is 8:58:33 AM
Promo Codes
Latest Trainer
• Skip Levels
  Show all Cheats & Trainers